summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/crf++')
-rw-r--r--app-text/crf++/crf++-0.54.ebuild1
-rw-r--r--app-text/crf++/crf++-0.58.ebuild4
-rw-r--r--app-text/crf++/files/crf++-automake-1.13.patch10
3 files changed, 14 insertions, 1 deletions
diff --git a/app-text/crf++/crf++-0.54.ebuild b/app-text/crf++/crf++-0.54.ebuild
index e282ca87c965..3a48217d2796 100644
--- a/app-text/crf++/crf++-0.54.ebuild
+++ b/app-text/crf++/crf++-0.54.ebuild
@@ -22,6 +22,7 @@ src_prepare() {
-e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
configure.in || die
+ epatch "${FILESDIR}"/${PN}-automake-1.13.patch
epatch "${FILESDIR}"/${P}-c++11.patch
# bug #365921
epatch "${FILESDIR}/${P}-gcc46.patch"
diff --git a/app-text/crf++/crf++-0.58.ebuild b/app-text/crf++/crf++-0.58.ebuild
index 7518e894e2e9..63fcdca38b66 100644
--- a/app-text/crf++/crf++-0.58.ebuild
+++ b/app-text/crf++/crf++-0.58.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="3"
@@ -22,6 +22,8 @@ src_prepare() {
-e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
configure.in || die
+ epatch "${FILESDIR}"/${PN}-automake-1.13.patch
+
eautoreconf
}
diff --git a/app-text/crf++/files/crf++-automake-1.13.patch b/app-text/crf++/files/crf++-automake-1.13.patch
new file mode 100644
index 000000000000..afff7edc0707
--- /dev/null
+++ b/app-text/crf++/files/crf++-automake-1.13.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -240,6 +240,6 @@
+ AC_MSG_RESULT([yes])
+
+ AC_SUBST(datarootdir)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AC_OUTPUT([Makefile Makefile.msvc swig/version.h])
+