summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/llpp')
-rw-r--r--app-text/llpp/llpp-22.ebuild2
-rw-r--r--app-text/llpp/llpp-9999.ebuild6
2 files changed, 6 insertions, 2 deletions
diff --git a/app-text/llpp/llpp-22.ebuild b/app-text/llpp/llpp-22.ebuild
index 5043975096f7..58d774e71ce3 100644
--- a/app-text/llpp/llpp-22.ebuild
+++ b/app-text/llpp/llpp-22.ebuild
@@ -47,7 +47,7 @@ src_compile() {
local ocaml=$(usex ocamlopt ocamlopt.opt ocamlc.opt)
local cmo=$(usex ocamlopt cmx cmo)
local cma=$(usex ocamlopt cmxa cma)
- local ccopt="$(freetype-config --cflags ) -O -include ft2build.h -D_GNU_SOURCE -DUSE_FONTCONFIG"
+ local ccopt="$(freetype-config --cflags ) -O -include ft2build.h -D_GNU_SOURCE -DUSE_FONTCONFIG -std=c99 -Wextra -Wall -pedantic-errors -Wunused-parameter -Wsign-compare -Wshadow"
#if use egl ; then
# ccopt+=" -DUSE_EGL $(pkg-config --cflags egl)"
# local egl="egl"
diff --git a/app-text/llpp/llpp-9999.ebuild b/app-text/llpp/llpp-9999.ebuild
index fc2df017ae0c..c39e01aa2979 100644
--- a/app-text/llpp/llpp-9999.ebuild
+++ b/app-text/llpp/llpp-9999.ebuild
@@ -45,7 +45,11 @@ src_compile() {
local ocaml=$(usex ocamlopt ocamlopt.opt ocamlc.opt)
local cmo=$(usex ocamlopt cmx cmo)
local cma=$(usex ocamlopt cmxa cma)
- local ccopt="$(freetype-config --cflags ) -O -include ft2build.h -D_GNU_SOURCE -DUSE_FONTCONFIG"
+ local ccopt="$(freetype-config --cflags ) -O -include ft2build.h -D_GNU_SOURCE -DUSE_FONTCONFIG -std=c99 -Wextra -Wall -pedantic-errors -Wunused-parameter -Wsign-compare -Wshadow"
+ #if use egl ; then
+ # ccopt+=" -DUSE_EGL $(pkg-config --cflags egl)"
+ # local egl="egl"
+ #fi
if use static ; then
local cclib=""
local slib=""