summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rpl/rpl-1.9.1.ebuild')
-rw-r--r--app-text/rpl/rpl-1.9.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/rpl/rpl-1.9.1.ebuild b/app-text/rpl/rpl-1.9.1.ebuild
new file mode 100644
index 000000000000..dcc99262524d
--- /dev/null
+++ b/app-text/rpl/rpl-1.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Intelligent recursive search/replace utility"
+HOMEPAGE="http://rpl.sourceforge.net/ https://github.com/rrthomas/rpl"
+SRC_URI="https://github.com/rrthomas/rpl/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/argparse-manpage[${PYTHON_USEDEP}]
+ sys-apps/help2man[nls]
+"
+
+python_compile_all() {
+ # Compile man file
+ emake rpl.1
+}