summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xmldiff')
-rw-r--r--app-text/xmldiff/Manifest1
-rw-r--r--app-text/xmldiff/metadata.xml3
-rw-r--r--app-text/xmldiff/xmldiff-0.6.10-r2.ebuild2
-rw-r--r--app-text/xmldiff/xmldiff-1.1.1.ebuild23
4 files changed, 28 insertions, 1 deletions
diff --git a/app-text/xmldiff/Manifest b/app-text/xmldiff/Manifest
index 93a6ee9f46bc..efbfe9d10446 100644
--- a/app-text/xmldiff/Manifest
+++ b/app-text/xmldiff/Manifest
@@ -1 +1,2 @@
DIST xmldiff-0.6.10.tar.gz 45827 BLAKE2B f4b97d4fa7063f1edb66ab1bd465dc81cd66f35233dcd3d8ae2cc1f13e9e841645ddf8848dcd3bafc45d44da218c8260b36f5210883f3963572b375173e6d687 SHA512 b183a6e94258c4d693fa97e759868dae2dca6088e3cf12cf08b40e82d18a375f02b12d62d0cfc03fb74a5138f32f6614f555b95a3062ba768d1cdaf3391cc95b
+DIST xmldiff-1.1.1.tar.gz 36429 BLAKE2B 2d84a1552851b0964ac837a30c61a99a3360292020251aa06ed71723e89b6a8f89a79107c69a317b16d810ee74241d38837d382b0dcb134b43f72f58ee2b6ea2 SHA512 cf65bdd827b76781b693089b8742f6358931456c4fdfd0f4b2a9e13b30101b48379ea9c2bf3dcb32d6d22198769262f2603172ffa877bec2ddfa5fabfdf74326
diff --git a/app-text/xmldiff/metadata.xml b/app-text/xmldiff/metadata.xml
index e7734cc5fb8a..30d3057f57c4 100644
--- a/app-text/xmldiff/metadata.xml
+++ b/app-text/xmldiff/metadata.xml
@@ -12,4 +12,7 @@
used as a library or as a command line tool. It can work either with XML
files or DOM trees.
</longdescription>
+ <upstream>
+ <remote-id type="github">Shoobx/xmldiff</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-text/xmldiff/xmldiff-0.6.10-r2.ebuild b/app-text/xmldiff/xmldiff-0.6.10-r2.ebuild
index e116f9beb7a1..7f33b19bd77d 100644
--- a/app-text/xmldiff/xmldiff-0.6.10-r2.ebuild
+++ b/app-text/xmldiff/xmldiff-0.6.10-r2.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="A tool that figures out the differences between two similar XML files"
-HOMEPAGE="https://www.logilab.org/project/xmldiff"
+HOMEPAGE="https://github.com/Shoobx/xmldiff https://www.logilab.org/project/xmldiff"
SRC_URI="ftp://ftp.logilab.fr/pub/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
diff --git a/app-text/xmldiff/xmldiff-1.1.1.ebuild b/app-text/xmldiff/xmldiff-1.1.1.ebuild
new file mode 100644
index 000000000000..955725e5043f
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-1.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="https://github.com/Shoobx/xmldiff https://www.logilab.org/project/xmldiff"
+SRC_URI="https://github.com/Shoobx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/future
+ dev-python/lxml
+ dev-python/six"
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst TODO.rst )