summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/discount/discount-2.1.8a-r1.ebuild2
-rw-r--r--app-text/dos2unix/dos2unix-7.3-r1.ebuild60
-rw-r--r--app-text/dvisvgm/dvisvgm-1.8.1.ebuild2
-rw-r--r--app-text/fdftk/Manifest2
-rw-r--r--app-text/multitail/Manifest2
-rw-r--r--app-text/multitail/files/multitail-6.0-as-needed.patch36
-rw-r--r--app-text/multitail/files/multitail-6.3-as-needed.patch31
-rw-r--r--app-text/multitail/multitail-6.2.1.ebuild55
-rw-r--r--app-text/multitail/multitail-6.3.ebuild67
-rw-r--r--app-text/multitail/multitail-6.4.1.ebuild2
-rw-r--r--app-text/stardict/Manifest1
-rw-r--r--app-text/stardict/files/stardict-3.0.3-zlib-1.2.5.2.patch39
-rw-r--r--app-text/stardict/stardict-3.0.4.ebuild132
-rw-r--r--app-text/stardict/stardict-3.0.6.ebuild2
-rw-r--r--app-text/tesseract/tesseract-3.04.00-r2.ebuild2
15 files changed, 66 insertions, 369 deletions
diff --git a/app-text/discount/discount-2.1.8a-r1.ebuild b/app-text/discount/discount-2.1.8a-r1.ebuild
index f799df1ea4fc..6f81d88dac6a 100644
--- a/app-text/discount/discount-2.1.8a-r1.ebuild
+++ b/app-text/discount/discount-2.1.8a-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm ~ia64 ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
IUSE="minimal"
src_prepare() {
diff --git a/app-text/dos2unix/dos2unix-7.3-r1.ebuild b/app-text/dos2unix/dos2unix-7.3-r1.ebuild
new file mode 100644
index 000000000000..b2c758b110d3
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls test"
+
+RDEPEND="
+ !app-text/hd2u
+ virtual/libintl"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( virtual/perl-Test-Simple )
+ dev-lang/perl"
+
+src_prepare() {
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}
diff --git a/app-text/dvisvgm/dvisvgm-1.8.1.ebuild b/app-text/dvisvgm/dvisvgm-1.8.1.ebuild
index e4ad428847e1..6be61fed5768 100644
--- a/app-text/dvisvgm/dvisvgm-1.8.1.ebuild
+++ b/app-text/dvisvgm/dvisvgm-1.8.1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="test"
# Tests don't work from $WORKDIR: kpathsea tries to search in relative
# directories from where the binary is executed.
diff --git a/app-text/fdftk/Manifest b/app-text/fdftk/Manifest
index c0967c4c9607..ea51fb4e27f7 100644
--- a/app-text/fdftk/Manifest
+++ b/app-text/fdftk/Manifest
@@ -1 +1 @@
-DIST FDFToolkitForUnix.tar.gz 5725906 SHA256 f7da280f258051f790efdcb6717c95f11acd410f825a0450864d4eea943afa51
+DIST FDFToolkitForUnix.tar.gz 5725906 SHA256 f7da280f258051f790efdcb6717c95f11acd410f825a0450864d4eea943afa51 SHA512 835438c5031464c169543d42a512ad691824dcea6d7f38e746bbe778adc9511eaa15c49ac2d4b3a92e4f831275e16a409e9e1e275983fb70309559ecdf686a66 WHIRLPOOL e3c44edb0745b6946023e0f483ae49de80132feb6a7e2b2b3051183226b54fd796405f8ac1e657e665360794adf4c3f42f24122830ff6a25a87e0c8529260152
diff --git a/app-text/multitail/Manifest b/app-text/multitail/Manifest
index 6652c69d710c..72dc712e9acb 100644
--- a/app-text/multitail/Manifest
+++ b/app-text/multitail/Manifest
@@ -1,3 +1 @@
-DIST multitail-6.2.1.tgz 166049 SHA256 1e586cd62c3cdb8089062c9670a6d8588359e2f8030b8b18dbc715ea59d92e11 SHA512 e1515c000c25be6532f590a2d030c44419866994c2744140d124c1b6ac73acf460b3a41ba6e0e8398350c180030eb69d13b537005b0744047d5c5a374b4cb123 WHIRLPOOL a14ec63145f412b21d7c769452c957fda1170daae725113991a8f4c1da19430516b7a27582f183b312a3388a6944beac0de64753684d60cc7255453254c2fd1c
-DIST multitail-6.3.tgz 155410 SHA256 1ba6afc2d0322bc09024664762a2fc7b8055c1d8ceb74acc442c49ccc84b817a SHA512 e16bb8f1db97e24ac917193cfcae77a0933c1d91cbebb8ba3d2f0af3cb9fe3b801b08f5a7b70b6f46c5edb4a251c81d5a8e03ec9599d40857a64f3cfa1f6734f WHIRLPOOL a37443f3ceaaedc1e708503c9cf9df01034a03dcc682406c0d93beb2a5f1c391f1ab0df7762d94fa43af8d155932bf23cd198e8a01b45fd3c5ee5963c62da24f
DIST multitail-6.4.1.tgz 155717 SHA256 8a6baecf3537c791f70645f3613bfea0c91a22040f2531bfe03b6d0cdd112134 SHA512 14d4785df257aaac8b3c1a5de8aa48a0b6c3e7829867e1fbc8d458636ecafcf506e09b12581cf562e1f503218b1729e47e9197f541bede90dc0a4d5e916b1c8b WHIRLPOOL 467d9fd6d089aebe597475d07217baadcb280ea952ae731310365a55046009c808b16657485c037f54dd746e2103f318c3555de04d4e14f2ab2ef19bbc408543
diff --git a/app-text/multitail/files/multitail-6.0-as-needed.patch b/app-text/multitail/files/multitail-6.0-as-needed.patch
deleted file mode 100644
index c78bd794f699..000000000000
--- a/app-text/multitail/files/multitail-6.0-as-needed.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -4,14 +4,15 @@ UTF8_SUPPORT=yes
- DESTDIR=/
- CONFIG_FILE=$(DESTDIR)/etc/multitail.conf
-
--CC=gcc
-+CC?=gcc
-+PKG_CONFIG?=pkg-config
- DEBUG=-g -D_FORTIFY_SOURCE=2 # -D_DEBUG # -pg # -D_DEBUG #-pg -W -pedantic # -pg #-fprofile-arcs
- ifeq ($(UTF8_SUPPORT),yes)
--LDFLAGS+=-lpanelw -lncursesw -lutil -lm $(DEBUG) -rdynamic
--CFLAGS+=-funsigned-char -D`uname` -O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
-+LIBS+=`$(PKG_CONFIG) --libs ncursesw panelw` -lutil -lm
-+CFLAGS+=-funsigned-char -D`uname` -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
- else
--LDFLAGS+=-lpanel -lncurses -lutil -lm $(DEBUG) -rdynamic
--CFLAGS+=-funsigned-char -D`uname` -O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\"
-+LIBS+=`$(PKG_CONFIG) --libs ncurses panel` -lutil -lm
-+CFLAGS+=-funsigned-char -D`uname` -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\"
- endif
-
- OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o
-@@ -19,10 +20,10 @@ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.
- all: multitail
-
- multitail: $(OBJS)
-- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o multitail
-+ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o multitail $(LIBS)
-
- multitail_ccmalloc: $(OBJS)
-- ccmalloc --no-wrapper $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail
-+ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o ccmultitail $(LIBS)
-
- install: multitail
- cp multitail $(DESTDIR)/usr/bin
diff --git a/app-text/multitail/files/multitail-6.3-as-needed.patch b/app-text/multitail/files/multitail-6.3-as-needed.patch
deleted file mode 100644
index 27b2cfaf1659..000000000000
--- a/app-text/multitail/files/multitail-6.3-as-needed.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -8,11 +8,11 @@ CONFIG_FILE=$(DESTDIR)/etc/multitail.conf
- CC?=gcc
- DEBUG=-g -O2 -Wall # -D_DEBUG # -pg # -D_DEBUG #-pg -W -pedantic # -pg #-fprofile-arcs
- ifeq ($(UTF8_SUPPORT),yes)
--LDFLAGS+=-lpanelw -lncursesw -lutil -lm
--CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT -D_FORTIFY_SOURCE=2
-+LIBS+=`$(PKG_CONFIG) --libs ncursesw panelw` -lutil -lm
-+CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
- else
--LDFLAGS+=-lpanel -lncurses -lutil -lm
--CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -D_FORTIFY_SOURCE=2
-+LIBS+=`$(PKG_CONFIG) --libs ncurses panel` -lutil -lm
-+CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\"
- endif
-
- OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o xclip.o
-@@ -20,10 +20,10 @@ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.
- all: multitail
-
- multitail: $(OBJS)
-- $(CC) $(OBJS) $(LDFLAGS) -o multitail
-+ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o $@ $(LIBS)
-
- multitail_ccmalloc: $(OBJS)
-- ccmalloc --no-wrapper $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail
-+ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o $@ $(LIBS)
-
- install: multitail
- mkdir -p $(DESTDIR)$(PREFIX)/bin
diff --git a/app-text/multitail/multitail-6.2.1.ebuild b/app-text/multitail/multitail-6.2.1.ebuild
deleted file mode 100644
index fc8ebcdd6ab8..000000000000
--- a/app-text/multitail/multitail-6.2.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tail with multiple windows"
-HOMEPAGE="http://www.vanheusden.com/multitail/"
-SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ia64 ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE="debug examples unicode"
-
-RDEPEND="sys-libs/ncurses:0=[unicode?]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RESTRICT="test" # bug #492270
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-6.0-as-needed.patch
-
- sed \
- -e '/gcc/d' \
- -e '/scan-build/d' \
- -e 's:make clean::g' \
- -e "/^DESTDIR/s:=.*$:=${EROOT}:g" \
- -i Makefile || die
-
- tc-export CC PKG_CONFIG
-
- use debug && append-flags "-D_DEBUG"
-}
-
-src_compile() {
- emake UTF8_SUPPORT=$(usex unicode)
-}
-
-src_install () {
- dobin multitail
-
- insinto /etc
- doins multitail.conf
-
- dodoc Changes readme.txt thanks.txt
- doman multitail.1
-
- dohtml manual.html
-
- docinto examples
- use examples && dodoc colors-example.{pl,sh} convert-{geoip,simple}.pl
-}
diff --git a/app-text/multitail/multitail-6.3.ebuild b/app-text/multitail/multitail-6.3.ebuild
deleted file mode 100644
index d3964c5449ce..000000000000
--- a/app-text/multitail/multitail-6.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tail with multiple windows"
-HOMEPAGE="http://www.vanheusden.com/multitail/"
-SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE="debug examples unicode"
-
-RDEPEND="
- sys-libs/ncurses:0=[unicode?]
- "
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RESTRICT="test" # bug #492270
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-as-needed.patch
-
- sed \
- -e '/gcc/d' \
- -e '/scan-build/d' \
- -e 's:make clean::g' \
- -e "/^DESTDIR/s:=.*$:=${EROOT}:g" \
- -i Makefile || die
-
- sed \
- -e "s:/usr/bin/xclip:${EPREFIX}/usr/bin/xclip:g" \
- -i xclip.c ${PN}.conf || die
-
- tc-export CC PKG_CONFIG
-
- use debug && append-flags "-D_DEBUG"
-}
-
-src_compile() {
- emake UTF8_SUPPORT=$(usex unicode)
-}
-
-src_install () {
- dobin multitail
-
- insinto /etc
- doins multitail.conf
-
- DOCS=( readme.txt thanks.txt )
- HTML_DOCS=( manual.html )
- einstalldocs
-
- doman multitail.1
-
- use examples && \
- docinto examples && \
- dodoc colors-example.{pl,sh} convert-{geoip,simple}.pl
-}
-
-pkg_postinst() {
- optfeature "send a buffer to the X clipboard" x11-misc/xclip
-}
diff --git a/app-text/multitail/multitail-6.4.1.ebuild b/app-text/multitail/multitail-6.4.1.ebuild
index d68465770e99..817c004a3577 100644
--- a/app-text/multitail/multitail-6.4.1.ebuild
+++ b/app-text/multitail/multitail-6.4.1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 hppa ~ia64 ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 hppa ia64 ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux"
IUSE="debug examples unicode"
RDEPEND="
diff --git a/app-text/stardict/Manifest b/app-text/stardict/Manifest
index c8cbd9eb24b4..bf64d7c75722 100644
--- a/app-text/stardict/Manifest
+++ b/app-text/stardict/Manifest
@@ -1,4 +1,3 @@
DIST QQWry.Dat.bz2 4114875 SHA256 3eda90ee8ea13ec88767336b078d2dfe2c971d6a31df60f409d526e3e29a4f83 SHA512 46fd677359a2144429eb9d16131ca6b19db1c086fa93e275aa3d702d3024a65d54064df931d1ed2ba5b0c1f7d9595a284f2a8995d9cd5aac96a45216422dc9ae WHIRLPOOL 456bab65658a8af76160f162fc66868c8a74653a88a1a115e2a20dd90ba9ae8a93b1aa1ee9856cc811d1b1229ca910868ea5db764a119ae9b31cbabf962cab5f
DIST WyabdcRealPeopleTTS.tar.bz2 84329208 SHA256 96a398eaef3e84f6f23e61683e6439913a4d44055e695dd4a1936f9340d64870 SHA512 1553e62c139ecb005bb04163147d94aa58e4ba7f9ee3172b760c6e4776587c12bf816c42e0131c82195b7c738ec9ee5082f39b974790f5cacd522367919beaa0 WHIRLPOOL 210c121c25c7726cee62c2f2beb3186f0799d68c5537442eda967694f176cbbbc6d09a8c3759de093226e283ae651348ed7173a9f93bbf776325fb656e19720c
-DIST stardict-3.0.4.tar.bz2 8961622 SHA256 c38b9d953fe0b2380a8aed4c98cb121ad83aff91a32af3c665198d8268b1dce8 SHA512 a1cbf58202b5430b0869955bfb7df961debab12abf55022f7c07537246c81dc182c3be50fa66273c13c289471c15afba74d15933cb202ae292f4388aa2fb6fd5 WHIRLPOOL b0476e5f38862e4c2a747206a8f1d8c55dc889d1138961390aa9f415ec310cabce242e7a4f484a4c260a004e3a8a152726cf936f0ec030586ddcd91979912aa0
DIST stardict-3.0.6.tar.bz2 9341740 SHA256 6a0a695a8977604e0509a3db1bc6a67e53599b14f29494ba942f21d2c26b82e7 SHA512 81d93324b6e8954af7c20ea6d2a3054bb564d786a21b1cb541c728da7a18a6e7ddb23e595055ccc77e6866bbb8c89fb4f17023e33664761dbe1ee8cd55768658 WHIRLPOOL 9502af310d5eba5ed23457fff9e9f00e2d8453873cece3c20e2c5daf861bd665fc7b9c8e292be5b1d886f9a9fd0d5ad9bd1d8fbd043d221e6637c1c8185f444f
diff --git a/app-text/stardict/files/stardict-3.0.3-zlib-1.2.5.2.patch b/app-text/stardict/files/stardict-3.0.3-zlib-1.2.5.2.patch
deleted file mode 100644
index 6a320bd4a9f2..000000000000
--- a/app-text/stardict/files/stardict-3.0.3-zlib-1.2.5.2.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-http://bugs.gentoo.org/401887
-
-diff --git a/lib/src/libcommon.cpp b/lib/src/libcommon.cpp
-index 16770a3..a4299e7 100644
---- a/lib/src/libcommon.cpp
-+++ b/lib/src/libcommon.cpp
-@@ -614,7 +614,7 @@ int unpack_zlib(const char* arch_file_name, const char* out_file_name)
- return EXIT_FAILURE;
- }
- while(true) {
-- len = gzread(get_impl(in), buf, buffer_size);
-+ len = gzread((gzFile)get_impl(in), buf, buffer_size);
- if(len < 0) {
- g_critical(read_file_err, arch_file_name, "");
- return EXIT_FAILURE;
-@@ -871,3 +871,8 @@ int remove_recursive(const std::string& path)
- return res;
- }
- }
-+
-+int gzclose_compat(void * file)
-+{
-+ return gzclose ((gzFile)file);
-+}
-diff --git a/lib/src/libcommon.h b/lib/src/libcommon.h
-index 10f13b4..bdcbf2f 100644
---- a/lib/src/libcommon.h
-+++ b/lib/src/libcommon.h
-@@ -187,8 +187,9 @@ namespace clib {
- typedef ResourceWrapper<FILE, FILE*, int, fclose> File;
- }
-
-+extern int gzclose_compat(void * file);
- namespace zip {
--typedef ResourceWrapper<void, void*, int, gzclose> gzFile;
-+typedef ResourceWrapper<void, void*, int, gzclose_compat> gzFile;
- }
-
- /* Create a new temporary file. Return file name in file name encoding.
diff --git a/app-text/stardict/stardict-3.0.4.ebuild b/app-text/stardict/stardict-3.0.4.ebuild
deleted file mode 100644
index 0dde8d48b782..000000000000
--- a/app-text/stardict/stardict-3.0.4.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# NOTE: Even though the *.dict.dz are the same as dictd/freedict's files,
-# their indexes seem to be in a different format. So we'll keep them
-# seperate for now.
-
-# NOTE: Festival plugin crashes, bug 188684. Disable for now.
-
-GNOME2_LA_PUNT=yes
-GCONF_DEBUG=no
-
-inherit eutils gnome2
-
-DESCRIPTION="A international dictionary supporting fuzzy and glob style matching"
-HOMEPAGE="https://code.google.com/p/stardict-3/"
-SRC_URI="https://${PN}-3.googlecode.com/files/${P}.tar.bz2
- pronounce? ( https://${PN}-3.googlecode.com/files/WyabdcRealPeopleTTS.tar.bz2 )
- qqwry? ( mirror://gentoo/QQWry.Dat.bz2 )"
-
-LICENSE="CPL-1.0 GPL-3 LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="espeak gnome gucharmap qqwry pronounce spell tools"
-
-RESTRICT="test"
-
-COMMON_DEPEND=">=dev-libs/glib-2.16
- dev-libs/libsigc++:2
- sys-libs/zlib
- >=x11-libs/gtk+-2.20:2
- gnome? (
- >=gnome-base/libbonobo-2
- >=gnome-base/libgnome-2
- >=gnome-base/libgnomeui-2
- >=gnome-base/gconf-2
- >=gnome-base/orbit-2
- )
- gucharmap? ( >=gnome-extra/gucharmap-2.22.1:0 )
- spell? ( >=app-text/enchant-1.2 )
- tools? (
- dev-libs/libpcre
- dev-libs/libxml2
- virtual/mysql
- )"
-RDEPEND="${COMMON_DEPEND}
- espeak? ( >=app-accessibility/espeak-1.29 )"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.3
- app-text/gnome-doc-utils
- dev-libs/libxslt
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
-
-src_prepare() {
- # These 2 fixes have been upstreamized for upcoming 3.0.5 differently, so drop 'em:
- epatch "${FILESDIR}"/${PN}-3.0.3-zlib-1.2.5.2.patch
- sed -i -e '/DEP_MODULES/s:glib-2.0:gmodule-2.0 &:' dict/configure || die
-
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- $(use_enable tools) \
- --disable-scrollkeeper \
- $(use_enable spell) \
- $(use_enable gucharmap) \
- --disable-festival \
- $(use_enable espeak) \
- $(use_enable qqwry) \
- --disable-updateinfo \
- $(use_enable gnome gnome-support) \
- --disable-gpe-support \
- --disable-schemas-install
-}
-
-src_install() {
- gnome2_src_install
-
- dodoc dict/doc/{Documentation,FAQ,HACKING,HowToCreateDictionary,Skins,StarDictFileFormat,Translation}
-
- if use qqwry; then
- insinto /usr/share/${PN}/data
- doins ../QQWry.Dat
- fi
-
- if use pronounce; then
- docinto WyabdcRealPeopleTTS
- dodoc ../WyabdcRealPeopleTTS/{README,readme.txt}
- rm -f ../WyabdcRealPeopleTTS/{README,readme.txt}
- insinto /usr/share
- doins -r ../WyabdcRealPeopleTTS
- fi
-
- # noinst_PROGRAMS with ${PN}_ prefix from tools/src/Makefile.am wrt #292773
- if use tools; then
- local app
- local apps="${PN}-editor pydict2dic olddic2newdic oxford2dic directory2dic
- dictd2dic wquick2dic ec50 directory2treedic treedict2dir jdictionary mova
- xmlinout soothill kanjidic2 powerword kdic 21tech 21shiji buddhist
- tabfile cedict edict duden ${PN}-dict-update degb2utf frgb2utf
- jpgb2utf gmx2utf rucn kingsoft wikipedia wikipediaImage babylon
- ${PN}2txt ${PN}-verify fest2dict i2e2dict downloadwiki
- ooo2dict myspell2dic exc2i2e dictbuilder tabfile2sql KangXi Unihan
- xiaoxuetang-ja wubi ydp2dict wordnet lingvosound2resdb
- resdatabase2dir dir2resdatabase ${PN}-index ${PN}-text2bin
- ${PN}-bin2text ${PN}-repair"
-
- for app in ${apps}; do
- newbin tools/src/${app} ${PN}_${app}
- done
- fi
-}
-
-pkg_postinst() {
- elog "Note: festival text to speech (TTS) plugin is not built. To use festival"
- elog 'TTS plugin, please, emerge festival and enable "Use TTS program." at:'
- elog '"Preferences -> Dictionary -> Sound" and fill in "Commandline" with:'
- elog '"echo %s | festival --tts"'
- elog
- elog "You will now need to install ${PN} dictionary files. If"
- elog "you have not, execute the below to get a list of dictionaries:"
- elog
- elog " emerge -s ${PN}-"
-
- gnome2_pkg_postinst
-}
diff --git a/app-text/stardict/stardict-3.0.6.ebuild b/app-text/stardict/stardict-3.0.6.ebuild
index 97d031ff10df..84a154545123 100644
--- a/app-text/stardict/stardict-3.0.6.ebuild
+++ b/app-text/stardict/stardict-3.0.6.ebuild
@@ -23,7 +23,7 @@ SRC_URI="mirror://sourceforge/${PN}-4/${P}.tar.bz2
LICENSE="CPL-1.0 GPL-3 LGPL-2"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 sparc x86"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 sparc x86"
IUSE="espeak gucharmap qqwry pronounce spell tools"
RESTRICT="test"
diff --git a/app-text/tesseract/tesseract-3.04.00-r2.ebuild b/app-text/tesseract/tesseract-3.04.00-r2.ebuild
index 08b632a81c40..903f5ba018e8 100644
--- a/app-text/tesseract/tesseract-3.04.00-r2.ebuild
+++ b/app-text/tesseract/tesseract-3.04.00-r2.ebuild
@@ -59,7 +59,7 @@ SRC_URI="https://github.com/${MY_PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm ppc ~ppc64 ~sparc x86"
+KEYWORDS="alpha amd64 ~arm ppc ppc64 ~sparc x86"
IUSE="doc examples jpeg opencl osd png +scrollview static-libs tiff training -webp linguas_ar linguas_bg linguas_ca linguas_chr linguas_cs linguas_de linguas_da linguas_el linguas_es linguas_fi linguas_fr linguas_he linguas_hi linguas_hu linguas_id linguas_it linguas_jp linguas_ko linguas_lt linguas_lv linguas_nl linguas_no linguas_pl linguas_pt linguas_ro linguas_ru linguas_sk linguas_sl linguas_sr linguas_sv linguas_th linguas_tl linguas_tr linguas_uk linguas_vi linguas_zh_CN linguas_zh_TW"