summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimoutliner/vimoutliner-0.3.6.ebuild')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.6.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.6.ebuild
new file mode 100644
index 000000000000..6f92f49a9514
--- /dev/null
+++ b/app-vim/vimoutliner/vimoutliner-0.3.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easy and fast outlining"
+HOMEPAGE="http://www.vimoutliner.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimoutliner"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
+ sed -i -e 's/g:vo_modules2load/g:vo_modules_load/' vimoutliner/vimoutlinerrc || die
+ rm -v install.sh || die
+ find "${S}" -type f -exec chmod a+r {} \; || die
+}