summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1-r1.ebuild b/dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1-r1.ebuild
new file mode 100644
index 000000000000..b6cce4ea1094
--- /dev/null
+++ b/dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools mono-env
+
+DESCRIPTION="C# binding for gkeyfile"
+HOMEPAGE="https://launchpad.net/gkeyfile-sharp https://github.com/mono/gkeyfile-sharp"
+SRC_URI="https://github.com/mono/${PN}/tarball/GKEYFILE_SHARP_0_1 -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( >=dev-dotnet/gtk-sharp-2.12.21 >=dev-dotnet/glib-sharp-2.12.9 )
+ || ( >=dev-dotnet/gtk-sharp-2.12.21 >=dev-dotnet/gtk-sharp-gapi-1.9 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ mv configure.in configure.ac
+ sed -i -e 's/gmcs/mcs/' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS
+}