summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/urjtag/urjtag-9999.ebuild')
-rw-r--r--dev-embedded/urjtag/urjtag-9999.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/dev-embedded/urjtag/urjtag-9999.ebuild b/dev-embedded/urjtag/urjtag-9999.ebuild
index 57288a015220..54e0951ff6ce 100644
--- a/dev-embedded/urjtag/urjtag-9999.ebuild
+++ b/dev-embedded/urjtag/urjtag-9999.ebuild
@@ -1,18 +1,15 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: figure out htf to make python.eclass work
+EAPI=7
-EAPI="5"
-
-inherit eutils ltprune multilib
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/urjtag/git"
inherit git-r3 autotools
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="mirror://sourceforge/urjtag/${P}.tar.bz2"
- KEYWORDS="amd64 ppc sparc x86"
+ SRC_URI="mirror://sourceforge/urjtag/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
fi
DESCRIPTION="Tool for communicating over JTAG with flash chips, CPUs, and many more"
@@ -20,37 +17,36 @@ HOMEPAGE="http://urjtag.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="ftd2xx ftdi readline static-libs usb"
+# TODO: Figure out if anyone wants the Python bindings
+IUSE="ftdi readline usb"
-DEPEND="ftdi? ( dev-embedded/libftdi:= )
- ftd2xx? ( dev-embedded/libftd2xx )
+DEPEND="ftdi? ( dev-embedded/libftdi:1 )
readline? ( sys-libs/readline:= )
usb? ( virtual/libusb:1 )"
RDEPEND="${DEPEND}
!dev-embedded/jtag"
src_prepare() {
+ default
+
if [[ ${PV} == "9999" ]] ; then
- mkdir -p m4
+ mkdir -p m4 || die
eautopoint
eautoreconf
fi
}
src_configure() {
- use ftd2xx && LDFLAGS="${LDFLAGS} -L/opt/$(get_libdir)"
+ use readline || export vl_cv_lib_readline=no
econf \
--disable-werror \
--disable-python \
- $(use_with readline) \
$(use_with ftdi libftdi) \
- $(use_with ftd2xx) \
- $(use_enable static-libs static) \
- $(use_with usb libusb 1.0)
+ $(use_with usb libusb)
}
src_install() {
default
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}