summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/avra/avra-1.4.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-embedded/avra/avra-1.4.1.ebuild b/dev-embedded/avra/avra-1.4.1.ebuild
index ae31d3fd6919..f39b49bd9b5d 100644
--- a/dev-embedded/avra/avra-1.4.1.ebuild
+++ b/dev-embedded/avra/avra-1.4.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Atmel AVR Assembler"
HOMEPAGE="https://github.com/hsoft/avra"
SRC_URI="https://github.com/hsoft/avra/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -12,7 +14,11 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
src_compile() {
- emake PREFIX=/usr CFLAGS="${CFLAGS} \$(CDEFS)" LDFLAGS="${LDFLAGS}"
+ emake \
+ CC=$(tc-getCC) \
+ PREFIX=/usr \
+ CFLAGS="${CFLAGS} \$(CDEFS)" \
+ LDFLAGS="${LDFLAGS}"
}
src_install() {