summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/snap-core')
-rw-r--r--dev-haskell/snap-core/Manifest1
-rw-r--r--dev-haskell/snap-core/snap-core-0.9.8.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/snap-core/Manifest b/dev-haskell/snap-core/Manifest
index 1952e064d5b8..38185bfabd88 100644
--- a/dev-haskell/snap-core/Manifest
+++ b/dev-haskell/snap-core/Manifest
@@ -1 +1,2 @@
DIST snap-core-0.9.7.2.tar.gz 91604 SHA256 526a8ebb758c8da5e966a37449fdb072af333275c1b7726ab6317ac93875f651 SHA512 b07e69a636d148d7f9ce107fd056e92aef8de7dcb7a422e6f4fa69db84abf46caae635bca9b5d6d7e25f597449b9f6dcb082b3c01119c7c56f5c296950bad21b WHIRLPOOL 36ee6a2d118218b839b7c45514423ca09a1923be31e62d0fb2c0e16a2ece6429da2b71b3629c08161c487f63d2737e98d517f904795c7524ee5a4fc6cc73038f
+DIST snap-core-0.9.8.0.tar.gz 91610 SHA256 47310fcd9c347883f5985c27c1fbcfac8c5783472a01afcc720bcc850622d2db SHA512 8bf98590294b3f8752255612b90378f19cec14067f2eaddab496cee5fddb4b8be954aada5a7831b81611d7ffc04d74156eb8fdb5d3c5f45e30259c7f86605585 WHIRLPOOL eb7de86ea6771811f310baf6b915fb387b2e4a00a86d3c4dd58e97e504688b435d42ccffb80e357d3d7a2065958998f628b50db139968f2944502ba1f3d8de0a
diff --git a/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild b/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
new file mode 100644
index 000000000000..cb4661a2f407
--- /dev/null
+++ b/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Snap: A Haskell Web Framework (core interfaces and types)"
+HOMEPAGE="http://snapframework.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug portable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/attoparsec-enumerator-0.3:=[profile?] <dev-haskell/attoparsec-enumerator-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/blaze-builder-enumerator-0.2:=[profile?] <dev-haskell/blaze-builder-enumerator-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.3:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/enumerator-0.4.15:=[profile?] <dev-haskell/enumerator-0.5:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
+ >=dev-haskell/monadcatchio-transformers-0.2.1:=[profile?] <dev-haskell/monadcatchio-transformers-0.4:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-2:=[profile?]
+ >=dev-haskell/regex-posix-0.95:=[profile?] <dev-haskell/regex-posix-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.4.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+ >=dev-haskell/zlib-enum-0.2.1:=[profile?] <dev-haskell/zlib-enum-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ || ( ( >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.2:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+ portable? ( >=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?] )
+ !portable? ( >=dev-haskell/bytestring-mmap-0.2.2:=[profile?] <dev-haskell/bytestring-mmap-0.3:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag portable portable)
+}