summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-lang/commons-lang-2.0-r3.ebuild')
-rw-r--r--dev-java/commons-lang/commons-lang-2.0-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/commons-lang/commons-lang-2.0-r3.ebuild b/dev-java/commons-lang/commons-lang-2.0-r3.ebuild
new file mode 100644
index 000000000000..ef47b3ce2f26
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-2.0-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Jakarta components to manipulate core java classes"
+HOMEPAGE="http://commons.apache.org/lang/"
+SRC_URI="mirror://apache/jakarta/commons/lang/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.4"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ java-pkg_dohtml DEVELOPERS-GUIDE.html PROPOSAL.html STATUS.html
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}