summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/trident')
-rw-r--r--dev-java/trident/Manifest1
-rw-r--r--dev-java/trident/files/1.3-build.xml.patch29
-rw-r--r--dev-java/trident/metadata.xml6
-rw-r--r--dev-java/trident/trident-1.3.ebuild47
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-java/trident/Manifest b/dev-java/trident/Manifest
new file mode 100644
index 000000000000..2e01d7e78b64
--- /dev/null
+++ b/dev-java/trident/Manifest
@@ -0,0 +1 @@
+DIST trident-1.3.zip 112050 SHA256 22184d8bf04652fa439ac18723ced54e2ab8958ec339aec1778680265437314c SHA512 2ecccf80c654ad8cff6a2907d4f81409034bd5cc07542e87db7b53a646fb63ee38a472eb778f6f77f6cf1885f8dc5b85d50a6a033ab430e7e03a07000463f68b WHIRLPOOL f26ce8563d0d0a37700a7f4adfe5a966579aed7d3079fa1043bbbbf060b3f1d31fb95c30572e829b1b4f61ccb94ef1b55a5a0c641335056fa85a939f76693c38
diff --git a/dev-java/trident/files/1.3-build.xml.patch b/dev-java/trident/files/1.3-build.xml.patch
new file mode 100644
index 000000000000..c82c3a18df3f
--- /dev/null
+++ b/dev-java/trident/files/1.3-build.xml.patch
@@ -0,0 +1,29 @@
+diff --git a/build.xml b/build.xml
+index 808ea3c..36e5859 100644
+--- a/build.xml
++++ b/build.xml
+@@ -84,7 +84,7 @@
+
+ <target name="compile.module.trident.production" description="compile module trident production classes">
+ <mkdir dir="${trident.output.dir}" />
+- <javac source="${javac.source}" target="${javac.target}" encoding="${javac.encoding}" destdir="${trident.output.dir}" debug="${javac.debug}" nowarn="${javac.generate.no.warnings}" memoryMaximumSize="${javac.max.memory}" fork="true" executable="${module.jdk.home.trident}/bin/javac">
++ <javac source="${javac.source}" target="${javac.target}" encoding="${javac.encoding}" destdir="${trident.output.dir}" debug="${javac.debug}" nowarn="${javac.generate.no.warnings}" memoryMaximumSize="${javac.max.memory}" fork="true">
+ <compilerarg line="${javac.args.trident}" />
+ <bootclasspath refid="trident.module.bootclasspath" />
+ <classpath refid="trident.module.classpath" />
+@@ -102,7 +102,7 @@
+
+ <target name="compile.module.trident.test" description="compile module trident test classes">
+ <mkdir dir="${trident.output.dir}" />
+- <javac source="${javac.source}" target="${javac.target}" encoding="${javac.encoding}" destdir="${trident.output.dir}" debug="${javac.debug}" nowarn="${javac.generate.no.warnings}" memoryMaximumSize="${javac.max.memory}" fork="true" executable="${module.jdk.home.trident}/bin/javac">
++ <javac source="${javac.source}" target="${javac.target}" encoding="${javac.encoding}" destdir="${trident.output.dir}" debug="${javac.debug}" nowarn="${javac.generate.no.warnings}" memoryMaximumSize="${javac.max.memory}" fork="true">
+ <compilerarg line="${javac.args.trident}" />
+ <bootclasspath refid="trident.module.bootclasspath" />
+ <classpath refid="trident.module.classpath" />
+@@ -189,4 +189,4 @@
+ <target name="clean" depends="clean.module.trident" description="cleanup all" />
+
+ <target name="all" depends="timestamp, init, clean, compile.module.trident, jar, compile.module.trident.test, jar-tst" description="build all" />
+-</project>
+\ No newline at end of file
++</project>
diff --git a/dev-java/trident/metadata.xml b/dev-java/trident/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/trident/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+
diff --git a/dev-java/trident/trident-1.3.ebuild b/dev-java/trident/trident-1.3.ebuild
new file mode 100644
index 000000000000..24de5640177f
--- /dev/null
+++ b/dev-java/trident/trident-1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java animation library"
+HOMEPAGE="https://kenai.com/projects/trident/pages/Home"
+SRC_URI="https://kenai.com/projects/trident/downloads/download/version%20${PV}%20-%20stable/${PN}-all.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+COMMON_DEPEND="dev-java/swt:3.7"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="timestamp init clean compile.module.trident jar"
+EANT_GENTOO_CLASSPATH="swt-3.7"
+EANT_EXTRA_ARGS="-Djdk.home=${JAVA_HOME}"
+
+java_prepare() {
+ mkdir build/classes -p || die
+ rm -r src/org/pushingpixels/trident/android/ || die
+ epatch "${FILESDIR}"/${PV}-*.patch
+}
+
+src_install() {
+ java-pkg_dojar drop/${PN}.jar
+
+ use source && java-pkg_dosrc src/*
+}