summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/DFB++/DFB++-1.2.0.ebuild')
-rw-r--r--dev-libs/DFB++/DFB++-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/DFB++/DFB++-1.2.0.ebuild b/dev-libs/DFB++/DFB++-1.2.0.ebuild
new file mode 100644
index 000000000000..d2d0781aa762
--- /dev/null
+++ b/dev-libs/DFB++/DFB++-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for DirectFB"
+HOMEPAGE="http://www.directfb.org/dfb++.xml"
+SRC_URI="http://www.directfb.org/downloads/Extras/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/DirectFB-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-directfb-api.patch #235041
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+}