summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/bcm2835/bcm2835-1.36.ebuild')
-rw-r--r--dev-libs/bcm2835/bcm2835-1.36.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/bcm2835/bcm2835-1.36.ebuild b/dev-libs/bcm2835/bcm2835-1.36.ebuild
new file mode 100644
index 000000000000..3be0b63388ea
--- /dev/null
+++ b/dev-libs/bcm2835/bcm2835-1.36.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Provides access to GPIO and other IO functions on the Broadcom BCM2835"
+HOMEPAGE="http://www.airspayce.com/mikem/bcm2835/"
+SRC_URI="http://www.airspayce.com/mikem/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_install() {
+ default
+ if use examples; then
+ dodoc -r examples
+ fi
+ if use doc; then
+ dohtml -r doc/html/.
+ fi
+}