summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild')
-rw-r--r--dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild b/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
new file mode 100644
index 000000000000..4d3465c29a27
--- /dev/null
+++ b/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="Blind-ID library for user identification using RSA blind signatures"
+HOMEPAGE="http://git.xonotic.org/?p=xonotic/d0_blind_id.git;a=summary"
+SRC_URI="mirror://github/divVerent/d0_blind_id/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/gmp:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( d0_blind_id.txt )
+
+src_prepare() {
+ # fix out-of-source build
+ sed -i \
+ -e 's, d0_rijndael.c, "$srcdir/d0_rijndael.c",' \
+ configure.ac || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-rijndael
+ --without-openssl
+ --without-tommath
+ )
+ autotools-utils_src_configure
+}