summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dclog/dclog-1.1.1-r1.ebuild')
-rw-r--r--dev-libs/dclog/dclog-1.1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/dclog/dclog-1.1.1-r1.ebuild b/dev-libs/dclog/dclog-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..eadccbc05a7d
--- /dev/null
+++ b/dev-libs/dclog/dclog-1.1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A logging library for C/C++ programs"
+HOMEPAGE="http://sourceforge.net/projects/dclog/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile -e '/ -o /s|${CFLAGS}|& ${LDFLAGS}|g' || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install || die "install failed"
+ dodoc VERSION
+ dohtml docs/html/*
+}