summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dotconf/dotconf-1.3.ebuild')
-rw-r--r--dev-libs/dotconf/dotconf-1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/dotconf/dotconf-1.3.ebuild b/dev-libs/dotconf/dotconf-1.3.ebuild
new file mode 100644
index 000000000000..6705ed1e747f
--- /dev/null
+++ b/dev-libs/dotconf/dotconf-1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="dot.conf configuration file parser"
+HOMEPAGE="http://www.github.com/williamh/dotconf"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+DEPEND=">=sys-devel/autoconf-2.58"
+RDEPEND=""
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ ewarn 'This version requires that you run revdep-rebuild after'
+ ewarn 'the upgrade.'
+}