summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/g-wrap/g-wrap-1.9.13.ebuild')
-rw-r--r--dev-libs/g-wrap/g-wrap-1.9.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/g-wrap/g-wrap-1.9.13.ebuild b/dev-libs/g-wrap/g-wrap-1.9.13.ebuild
new file mode 100644
index 000000000000..ab8d519622f3
--- /dev/null
+++ b/dev-libs/g-wrap/g-wrap-1.9.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A tool for exporting C libraries into Scheme"
+HOMEPAGE="http://www.nongnu.org/g-wrap/"
+SRC_URI="http://download.savannah.gnu.org/releases/g-wrap/${P}.tar.gz"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+# guile-lib for srfi-34, srfi-35
+RDEPEND="
+ dev-libs/glib:2
+ dev-scheme/guile-lib
+ dev-scheme/guile[deprecated]
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/indent"
+
+MAKEOPTS+=" -j1"
+
+src_configure() {
+ econf --disable-Werror --with-glib
+}