summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/guiloader/guiloader-2.21.0.ebuild')
-rw-r--r--dev-libs/guiloader/guiloader-2.21.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/guiloader/guiloader-2.21.0.ebuild b/dev-libs/guiloader/guiloader-2.21.0.ebuild
new file mode 100644
index 000000000000..fc387d6fe859
--- /dev/null
+++ b/dev-libs/guiloader/guiloader-2.21.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="library to create GTK+ interfaces from GuiXml at runtime"
+HOMEPAGE="http://www.crowdesigner.org"
+SRC_URI="http://nothing-personal.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+LANGS="ru"
+
+RDEPEND=">=x11-libs/gtk+-2.22:2
+ >=dev-libs/glib-2.26:2"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.18 )"
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/{authors.txt,news.{ru,en}.txt,readme.{ru,en}.txt} || die
+}