summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/isl/isl-0.11.1.ebuild')
-rw-r--r--dev-libs/isl/isl-0.11.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/isl/isl-0.11.1.ebuild b/dev-libs/isl/isl-0.11.1.ebuild
new file mode 100644
index 000000000000..451635a73c29
--- /dev/null
+++ b/dev-libs/isl/isl-0.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A library for manipulating integer points bounded by affine constraints"
+HOMEPAGE="http://www.kotnet.org/~skimo/isl/"
+SRC_URI="http://www.kotnet.org/~skimo/isl/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/gmp"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog AUTHORS doc/manual.pdf )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.07-gdb-autoload-dir.patch
+
+ # m4/ax_create_pkgconfig_info.m4 is broken but avoid eautoreconf
+ # http://groups.google.com/group/isl-development/t/37ad876557e50f2c
+ sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die #382737
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}