summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcaldav/libcaldav-0.6.2.ebuild')
-rw-r--r--dev-libs/libcaldav/libcaldav-0.6.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libcaldav/libcaldav-0.6.2.ebuild b/dev-libs/libcaldav/libcaldav-0.6.2.ebuild
new file mode 100644
index 000000000000..25ad8752bbcf
--- /dev/null
+++ b/dev-libs/libcaldav/libcaldav-0.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="C library implementing client support for CalDAV"
+HOMEPAGE="http://libcaldav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libcaldav/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/glib
+ net-misc/curl[ssl,gnutls(+),curl_ssl_gnutls(+)]
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )
+"
+
+src_configure() {
+ econf $(use_enable doc)
+}