summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libe/libe-0.9.0.ebuild')
-rw-r--r--dev-libs/libe/libe-0.9.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/libe/libe-0.9.0.ebuild b/dev-libs/libe/libe-0.9.0.ebuild
new file mode 100644
index 000000000000..cf84d6d43e58
--- /dev/null
+++ b/dev-libs/libe/libe-0.9.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=4
+
+inherit eutils
+
+# bit messy at the moment, next release should fix it I hope
+RESTRICT="test"
+
+DESCRIPTION="Hyperdex libe support library"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND=">=dev-libs/libpo6-0.6.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/_strtoui64/strtoul/' e/convert.h || die
+}