summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libestr/libestr-0.1.3.ebuild')
-rw-r--r--dev-libs/libestr/libestr-0.1.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/libestr/libestr-0.1.3.ebuild b/dev-libs/libestr/libestr-0.1.3.ebuild
new file mode 100644
index 000000000000..21006711d28f
--- /dev/null
+++ b/dev-libs/libestr/libestr-0.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Library for some string essentials"
+HOMEPAGE="http://libestr.adiscon.com/"
+SRC_URI="http://libestr.adiscon.com/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm ~hppa x86"
+IUSE="debug static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable debug) $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ find "${D}" -name "*.la" -delete || die
+}