summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libp11/libp11-0.2.8-r3.ebuild')
-rw-r--r--dev-libs/libp11/libp11-0.2.8-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libp11/libp11-0.2.8-r3.ebuild b/dev-libs/libp11/libp11-0.2.8-r3.ebuild
new file mode 100644
index 000000000000..69765ed31517
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.2.8-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A library implementing a layer on top of PKCS#11 API to make using PKCS#11 implementations easier"
+HOMEPAGE="https://github.com/opensc/libp11/wiki"
+SRC_URI="mirror://sourceforge/opensc/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-ltdl.patch
+ epatch "${FILESDIR}"/${P}-variable-buffer-size.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --htmldir="/usr/share/doc/${PF}/html" \
+ --enable-shared --disable-static \
+ --enable-doc \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}