summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild')
-rw-r--r--dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild b/dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild
new file mode 100644
index 000000000000..ec0b34b30d5a
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A Qt implementation of XDG standards"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+CDEPEND="
+ sys-apps/file
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+DEPEND="${CDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+RDEPEND="${CDEPEND}
+ x11-misc/xdg-utils
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ $(cmake-utils_use test BUILD_TESTS)
+ )
+ cmake-utils_src_configure
+}