summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/msgpack/msgpack-0.5.9.ebuild')
-rw-r--r--dev-libs/msgpack/msgpack-0.5.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/msgpack/msgpack-0.5.9.ebuild b/dev-libs/msgpack/msgpack-0.5.9.ebuild
new file mode 100644
index 000000000000..bfa421299fdc
--- /dev/null
+++ b/dev-libs/msgpack/msgpack-0.5.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
+HOMEPAGE="http://msgpack.org/ https://github.com/msgpack/msgpack-c/"
+SRC_URI="https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+DEPEND="test? ( >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}] )"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ sed -i 's/-O3 //' configure.in || die
+ autotools-multilib_src_prepare
+}