summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/popt/popt-1.16-r1.ebuild')
-rw-r--r--dev-libs/popt/popt-1.16-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/popt/popt-1.16-r1.ebuild b/dev-libs/popt/popt-1.16-r1.ebuild
new file mode 100644
index 000000000000..1f6c1ae77251
--- /dev/null
+++ b/dev-libs/popt/popt-1.16-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="http://rpm5.org/"
+SRC_URI="http://rpm5.org/files/popt/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-popt-pkgconfig-libdir.patch #349558
+ sed -i -e 's:lt-test1:test1:' testit.sh || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README || die
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}