summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/pugixml/pugixml-1.6.ebuild')
-rw-r--r--dev-libs/pugixml/pugixml-1.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/pugixml/pugixml-1.6.ebuild b/dev-libs/pugixml/pugixml-1.6.ebuild
new file mode 100644
index 000000000000..2b07f83f4314
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="http://pugixml.org/ https://github.com/zeux/pugixml/"
+SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+S=${WORKDIR}/${P}/scripts
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
+ cmake-utils_src_configure
+}