summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/sdformat/sdformat-2.3.2.ebuild')
-rw-r--r--dev-libs/sdformat/sdformat-2.3.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/sdformat/sdformat-2.3.2.ebuild b/dev-libs/sdformat/sdformat-2.3.2.ebuild
new file mode 100644
index 000000000000..c569a0af61e3
--- /dev/null
+++ b/dev-libs/sdformat/sdformat-2.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot
+
+DESCRIPTION="Simulation Description Format (SDF) parser"
+HOMEPAGE="http://sdformat.org/"
+SRC_URI="https://bitbucket.org/osrf/sdformat/get/${PN}$(get_major_version)_${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/urdfdom
+ dev-libs/tinyxml
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+S="${WORKDIR}/${PN}$(get_major_version)_${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DUSE_EXTERNAL_URDF=ON"
+ "-DUSE_EXTERNAL_TINYXML=ON"
+ )
+ cmake-utils_src_configure
+}