summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild b/dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild
new file mode 100644
index 000000000000..2d2237a52f06
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/2"
+KEYWORDS="amd64 ~arm x86"
+IUSE="static-libs test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9_p20121123-test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build static-libs STATIC_LIBS)
+ $(cmake-utils_use_build test TEST)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_test
+ ./test || die "Tests failed"
+}