summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/yajl/yajl-2.0.4-r1.ebuild')
-rw-r--r--dev-libs/yajl/yajl-2.0.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/yajl/yajl-2.0.4-r1.ebuild b/dev-libs/yajl/yajl-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..4abe1e8429e1
--- /dev/null
+++ b/dev-libs/yajl/yajl-2.0.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base cmake-multilib
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="http://lloyd.github.com/yajl/"
+SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix_static_linking.patch
+)
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/lloyd-${PN}-* "${S}"
+}
+
+src_test() {
+ emake -C ${CMAKE_BUILD_DIR} test
+}