summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libreport/libreport-2.9.5.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/dev-libs/libreport/libreport-2.9.5.ebuild b/dev-libs/libreport/libreport-2.9.5.ebuild
index fab10399795b..c9250a6e69a3 100644
--- a/dev-libs/libreport/libreport-2.9.5.ebuild
+++ b/dev-libs/libreport/libreport-2.9.5.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit autotools ltprune python-r1 user
+inherit autotools python-r1 user
DESCRIPTION="Generic library for reporting software bugs"
HOMEPAGE="https://github.com/abrt/libreport"
@@ -39,6 +39,7 @@ DEPEND="${COMMON_DEPEND}
app-text/asciidoc
app-text/xmlto
>=dev-util/intltool-0.3.50
+ sys-apps/systemd
>=sys-devel/gettext-0.17
virtual/pkgconfig
"
@@ -66,15 +67,23 @@ src_configure() {
--without-python2
$(usex python "--with-python3" "--without-python3")
)
+ if use python; then
+ python_foreach_impl run_in_build_dir \
+ econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
- econf "${myargs[@]}"
+src_compile() {
+ use python && python_foreach_impl run_in_build_dir default
}
src_install() {
-
+ use python && python_foreach_impl run_in_build_dir default
# Need to set correct ownership for use by app-admin/abrt
diropts -o abrt -g abrt
keepdir /var/spool/abrt
- prune_libtool_files --modules
+ find "${D}" -name '*.la' -exec rm -f {} + || die
}