summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/camlzip-1.06.ebuild16
-rw-r--r--dev-ml/camlzip/camlzip-1.07.ebuild17
-rw-r--r--dev-ml/camlzip/camlzip-1.10.ebuild9
3 files changed, 21 insertions, 21 deletions
diff --git a/dev-ml/camlzip/camlzip-1.06.ebuild b/dev-ml/camlzip/camlzip-1.06.ebuild
index 4fed4a00664c..ea2362cc8b90 100644
--- a/dev-ml/camlzip/camlzip-1.06.ebuild
+++ b/dev-ml/camlzip/camlzip-1.06.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit findlib eutils
-
-IUSE="+ocamlopt"
+inherit findlib
DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
@@ -14,9 +12,12 @@ SRC_URI="http://forge.ocamlcore.org/frs/download.php/1616/${P}.tar.gz"
SLOT="1/${PV}"
LICENSE="LGPL-2.1"
KEYWORDS="amd64 ppc x86"
+IUSE="+ocamlopt"
-RDEPEND=">=dev-lang/ocaml-4.05:=[ocamlopt?]
- >=sys-libs/zlib-1.1.3"
+RDEPEND="
+ >=dev-lang/ocaml-4.05:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3
+"
DEPEND="${RDEPEND}"
src_compile() {
@@ -28,6 +29,7 @@ src_compile() {
src_install() {
findlib_src_preinst
+
emake DESTDIR="${D}" install-findlib
dodoc README Changes
diff --git a/dev-ml/camlzip/camlzip-1.07.ebuild b/dev-ml/camlzip/camlzip-1.07.ebuild
index 547fe00d0c83..448875803b1b 100644
--- a/dev-ml/camlzip/camlzip-1.07.ebuild
+++ b/dev-ml/camlzip/camlzip-1.07.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit findlib eutils versionator
-
-IUSE="+ocamlopt"
+inherit findlib
DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
HOMEPAGE="https://github.com/xavierleroy/camlzip"
-SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(delete_all_version_separators ${PV}).tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
SLOT="1/${PV}"
LICENSE="LGPL-2.1"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
RDEPEND=">=dev-lang/ocaml-4.05:=[ocamlopt?]
- >=sys-libs/zlib-1.1.3"
+ >=sys-libs/zlib-1.1.3"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}-rel$(delete_all_version_separators ${PV})"
-
src_compile() {
emake all
if use ocamlopt; then
@@ -30,6 +28,7 @@ src_compile() {
src_install() {
findlib_src_preinst
+
emake DESTDIR="${D}" install-findlib
dodoc README Changes
diff --git a/dev-ml/camlzip/camlzip-1.10.ebuild b/dev-ml/camlzip/camlzip-1.10.ebuild
index 181f9c64d19a..244b689e332a 100644
--- a/dev-ml/camlzip/camlzip-1.10.ebuild
+++ b/dev-ml/camlzip/camlzip-1.10.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit findlib
-IUSE="+ocamlopt"
-
DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
HOMEPAGE="https://github.com/xavierleroy/camlzip"
SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
SLOT="1/${PV}"
LICENSE="LGPL-2.1"
KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
+IUSE="+ocamlopt"
RDEPEND=">=dev-lang/ocaml-4.05:=[ocamlopt?]
>=sys-libs/zlib-1.1.3"
@@ -24,8 +24,6 @@ QA_FLAGS_IGNORED=(
"/usr/lib.*/ocaml/zip/zip.cmxs"
)
-S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
-
src_compile() {
emake all
if use ocamlopt; then
@@ -35,6 +33,7 @@ src_compile() {
src_install() {
findlib_src_preinst
+
emake DESTDIR="${D}" install-findlib
dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a