summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-http')
-rw-r--r--dev-php/pecl-http/Manifest2
-rw-r--r--dev-php/pecl-http/pecl-http-2.6.0.ebuild58
-rw-r--r--dev-php/pecl-http/pecl-http-3.1.0.ebuild56
3 files changed, 116 insertions, 0 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index d3339f248e96..d8c5832bec85 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,2 +1,4 @@
DIST pecl_http-2.5.6.tgz 200469 SHA256 8435eb9082b8fdc56b630e3d3d8e63617a3bc43d360f6f49fbd7b1856b266be4 SHA512 a4ddb2e55b537a240dc79ad38665f9cb79ef56a70f50e0393ca19c36f744c21374ba801e31e68545516c4be98cff65587ee91b2b25f05dd587120afcb87dfe4a WHIRLPOOL d4d2158b610c959a558b450a79a77a7f9de53d6e75982e920c4b64d48731139223659af149b9894c2fee1a477005af34a57cb33a806429e11446d5162b031b89
+DIST pecl_http-2.6.0.tgz 217673 SHA256 ddbf3eea3d1c7004a7dd83b5864aee5f87b1b6032bc281c08ccc62f83b9931ed SHA512 12d18049411a4133008449a1e7458a3055322dc337f421e0e2be126ec965f15b0189af6fccd9ca4537c48819c763b9e020906ac6d09d87ead92f4436fac595ad WHIRLPOOL 976a3ba0f37e78f97c4cc4884e61b2c14cd8760e48be2da0743a3b7adc44198984ff748ebed63885f012a14c8e016a57247685a576cc90e57c6bfbba59a4e862
DIST pecl_http-3.0.1.tgz 197372 SHA256 4e45ea546e3245669887ec98187666ccb4aa3df15078335b1c02c824c8165031 SHA512 344ae45987269d9505ffed6059be378005298d89c5e39bda6f771d8bf5a1998e91c214c03d32b9c78329c95e4928d35d3659dd3a1c70071aa5b2bd2763852098 WHIRLPOOL 76538ec0b94ef5d63808b625a8e73ab499c2afc78cd0f31823dcea4de66d865f7cf8387cc67eac1f19fec032a7ac7b7775685048ac0c6f76fadccfc1d932026c
+DIST pecl_http-3.1.0.tgz 214166 SHA256 e3de67b156e7d5f6c2e5eb1e2b5f0acceb7004f1260d68c9f8b2c0f9629aabf0 SHA512 1c272aa476106bb61848f175f0ba6715b3d8928f70cdac1a673cc87c2dc780dff5434a3bc595d5e8a1ef7b847a1d2e214f9e9ae80b8b5d1f80a299febc85b0ea WHIRLPOOL 8a6cb8689001e794b590ad2b0b9c873a8fd805f37726e61c2b617d962a94b3cf87c2d280f665b42bce7d8583415718f505a4f826ac616bcead2bfe2c9295fa55
diff --git a/dev-php/pecl-http/pecl-http-2.6.0.ebuild b/dev-php/pecl-http/pecl-http-2.6.0.ebuild
new file mode 100644
index 000000000000..2b2f983495bd
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-2.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="2"
+IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
+
+DEPEND="php_targets_php5-6? (
+ dev-libs/libevent
+ dev-php/pecl-propro:0[php_targets_php5-6]
+ dev-php/pecl-raphf:0[php_targets_php5-6]
+ net-dns/libidn
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
+ !ssl? ( net-misc/curl[-ssl] )
+ dev-lang/php:5.6[hash,session,iconv] )"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ php_targets_php7-0? ( dev-php/pecl-http:7[php_targets_php7-0] )
+ php_targets_php7-1? ( dev-php/pecl-http:7[php_targets_php7-1] )"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
+
+pkg_postinst() {
+ ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
+ ewarn "Please review the documentation and update your code."
+}
diff --git a/dev-php/pecl-http/pecl-http-3.1.0.ebuild b/dev-php/pecl-http/pecl-http-3.1.0.ebuild
new file mode 100644
index 000000000000..d74da5940a22
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-3.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0 php7-1"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="7"
+IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
+
+DEPEND="dev-libs/libevent
+ dev-php/pecl-propro:7[php_targets_php5-6?,php_targets_php7-0?,php_targets_php7-1?]
+ dev-php/pecl-raphf:7[php_targets_php5-6?,php_targets_php7-0?,php_targets_php7-1?]
+ net-dns/libidn
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
+ !ssl? ( net-misc/curl[-ssl] )
+ php_targets_php7-0? ( dev-lang/php:7.0[hash,session,iconv] )
+ php_targets_php7-1? ( dev-lang/php:7.1[hash,session,iconv] )"
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-http:2[php_targets_php5-6] )"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
+
+pkg_postinst() {
+ ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
+ ewarn "Please review the documentation and update your code."
+}