summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phpDocumentor')
-rw-r--r--dev-php/phpDocumentor/Manifest2
-rw-r--r--dev-php/phpDocumentor/files/channel.xml16
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild41
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild29
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild4
5 files changed, 2 insertions, 90 deletions
diff --git a/dev-php/phpDocumentor/Manifest b/dev-php/phpDocumentor/Manifest
index b7f085e8fa02..837251cdb83c 100644
--- a/dev-php/phpDocumentor/Manifest
+++ b/dev-php/phpDocumentor/Manifest
@@ -1,3 +1 @@
-DIST phpDocumentor-2.7.0.tgz 16118916 BLAKE2B de8538d7b45b1d266fa3dfafcea7d9d6ff91972419aeea334058bf9655f98cfc9ee8ba3a3205f4f939dea462b54c9c30425ec80172a394498b3da2c4d230a72a SHA512 068f2470f73ea6940077c23f5565e737d6065e881b9d1456fc617b00c285cc2358773afc16e97e3d9403b5caaaa32a9dcd360bfc91decf349f4b100fee4a9129
-DIST phpDocumentor-2.8.2.phar 33079646 BLAKE2B cb66562a6417cb9015f432be221cfaf4e7c577301e3cbdcf09a2f1add7e42ddc2fd6cda91c4a78a8a41f9ceebc60bcffe3bccb8b12077be565b2f6529cff1d78 SHA512 ef47483147358d423595d6c771971481b99338adeed0f2742ab6856925d3a1d501d4e786aab75cba5dc2306728aef6bf8fc4cfd8ea35d5d9c903f1afa5695c2a
DIST phpDocumentor-2.9.0.phar 18276081 BLAKE2B 988d9ae15a369c94d6dd83d68b64054d4d1829d651ae28a5082913ebd47666a73f5e48d331c09561777b58c6716707f4751b047e1aad9545d83ac9c964933b80 SHA512 62efc492d387675f753094bf4c42f890808bc3f45ae4a6908a519722af11ffbda41b47100e68f12e5b73a2eaa49fe8afc8143c751518a2a68b10afa18f896f10
diff --git a/dev-php/phpDocumentor/files/channel.xml b/dev-php/phpDocumentor/files/channel.xml
deleted file mode 100644
index fab798db9a95..000000000000
--- a/dev-php/phpDocumentor/files/channel.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" ?>
-<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
- <name>pear.phpdoc.org</name>
- <summary>phpdoc PEAR channel</summary>
- <suggestedalias>phpdoc</suggestedalias>
- <servers>
- <primary>
- <rest>
- <baseurl type="REST1.0">http://pear.phpdoc.org//rest/</baseurl>
- <baseurl type="REST1.1">http://pear.phpdoc.org//rest/</baseurl>
- <baseurl type="REST1.2">http://pear.phpdoc.org//rest/</baseurl>
- <baseurl type="REST1.3">http://pear.phpdoc.org//rest/</baseurl>
- </rest>
- </primary>
- </servers>
-</channel>
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild
deleted file mode 100644
index 7e5b156e075d..000000000000
--- a/dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_PEAR_DOMAIN="pear.phpdoc.org"
-PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
-
-inherit php-pear-r2
-
-DESCRIPTION="Automatic documenting of php api directly from the source"
-SRC_URI="http://${PHP_PEAR_URI}/get/${PEAR_P}.tgz"
-LICENSE="MIT"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc"
-
-# block old version that provides the same binary
-DEPEND="!dev-php/PEAR-PhpDocumentor"
-RDEPEND="media-gfx/graphviz
- dev-lang/php:*[iconv,intl,xmlreader,xslt]"
-
-src_prepare() {
- sed -i -e "s~@php_dir@~${EPREFIX}/usr/share/php~" \
- "${S}/bin/phpdoc" || die
- eapply_user
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/phpdoc
- insinto /usr/share/php/${PN}
- doins -r vendor src/* phpdoc.dist.xml bin/phpdoc.php
- insinto /usr/share/php/data/${PN}
- doins -r ansible data features box.json composer.json composer.lock phpmd.xml.dist wercker.yml
- # install manual, tutorial, reference material
- use doc && dodoc -r docs/*
- php-pear-r2_install_packagexml
- einstalldocs
-}
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild
deleted file mode 100644
index 1e4d18cd3495..000000000000
--- a/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Automatic documenting of php api directly from the source"
-HOMEPAGE="http://phpdoc.org"
-SRC_URI="https://github.com/${PN}/${PN}2/releases/download/v${PV}/${PN}.phar -> ${P}.phar"
-
-LICENSE="MIT"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-# block old version that provides the same binary
-DEPEND="!dev-php/PEAR-PhpDocumentor"
-RDEPEND="media-gfx/graphviz
- dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
-S="${WORKDIR}"
-
-src_unpack() { :; }
-
-src_install() {
- insinto /usr/share/php/${PN}
- insopts -m755
- newins "${DISTDIR}/${P}.phar" ${PN}.phar
- dosym /usr/share/php/${PN}/${PN}.phar /usr/bin/phpdoc
-}
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
index dac43364c339..48f99127a9eb 100644
--- a/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
+++ b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
@@ -14,8 +14,8 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
# block old version that provides the same binary
-DEPEND="!dev-php/PEAR-PhpDocumentor"
-RDEPEND="media-gfx/graphviz
+RDEPEND="!dev-php/PEAR-PhpDocumentor
+ media-gfx/graphviz
dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
S="${WORKDIR}"