summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/tcpdf')
-rw-r--r--dev-php/tcpdf/Manifest1
-rw-r--r--dev-php/tcpdf/tcpdf-6.2.16.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-php/tcpdf/Manifest b/dev-php/tcpdf/Manifest
index 50688f6c7e3d..4e61a79d9483 100644
--- a/dev-php/tcpdf/Manifest
+++ b/dev-php/tcpdf/Manifest
@@ -1 +1,2 @@
DIST tcpdf-6.2.13.tar.gz 17003733 BLAKE2B c6cae507c7abcc18e9135d102c334b161acf9680c41f158116c001962f22f06038c1c3eaa36aa78ae521c22d943e309367162c38fb4e759b8f2399ca0f12852b SHA512 df140a305b17e868d5af1a9cfe07f76c1c511f437e70ce09484049c48e7f4501d7b59ad2dbccea4daaee283867fa71ec03924aa40d37ed495b77f65383f6ef85
+DIST tcpdf-6.2.16.tar.gz 17006033 BLAKE2B a4a9b502812bca3babe9d89bc215e75c951a2f3649ac01cf7327d5e13ccfd36e9586eb15a712fd48245f504ace2bcf7075413f9ee06526f4dec5c7d6c3e34b9d SHA512 302022636cd2c178e2d015b702188d59b608855110928e253daf7dd14e117a6770ad85385023c7970f13347142c60cc62a8fbdcee471364c47cb499fc3fbaa6c
diff --git a/dev-php/tcpdf/tcpdf-6.2.16.ebuild b/dev-php/tcpdf/tcpdf-6.2.16.ebuild
new file mode 100644
index 000000000000..5b1b109e8504
--- /dev/null
+++ b/dev-php/tcpdf/tcpdf-6.2.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="TCPDF is a FLOSS PHP class for generating PDF documents"
+HOMEPAGE="http://www.tcpdf.org/"
+SRC_URI="https://github.com/tecnickcom/TCPDF/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Main source is LGPL-3+, some included fonts have other licenses
+LICENSE="LGPL-3+ GPL-3 BitstreamVera GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php"
+
+S="${WORKDIR}/${P^^}"
+
+src_install() {
+ insinto /etc
+ doins config/tcpdf_config.php
+ # Create a symlink for the config file, because the library will only
+ # look for it in its own source tree (not in /etc where we've put it).
+ dosym ../../../../../etc/tcpdf_config.php "/usr/share/php/${PN}/config/tcpdf_config.php"
+
+ exeinto "/usr/share/php/${PN}/tools"
+ doexe tools/tcpdf_addfont.php
+
+ insinto "/usr/share/php/${PN}"
+ doins tcpdf*.php
+ doins -r include fonts
+ dodoc CHANGELOG.TXT README.md
+
+ use examples && dodoc -r examples
+}