summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild31
-rw-r--r--dev-php/PEAR-XML_RSS/files/XML_RSS-1.1.0-php8.patch12
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..0511a5abb0a6
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="PHP parser for RDF and RSS documents"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-php/PEAR-XML_Parser-1.3.8-r1"
+BDEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+PATCHES=( "${FILESDIR}/XML_RSS-1.1.0-php8.patch" )
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/_Framework_/\\Framework\\/' \
+ -e 's/_TextUI_/\\TextUI\\/' \
+ tests/*.php
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/XML/RSS.php" \
+ --cache-result-file="${T}/test-results.cache" tests || die
+}
diff --git a/dev-php/PEAR-XML_RSS/files/XML_RSS-1.1.0-php8.patch b/dev-php/PEAR-XML_RSS/files/XML_RSS-1.1.0-php8.patch
new file mode 100644
index 000000000000..b78765cb80ea
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/files/XML_RSS-1.1.0-php8.patch
@@ -0,0 +1,12 @@
+diff -aurN a/XML/RSS.php b/XML/RSS.php
+--- a/XML/RSS.php 2017-03-07 14:16:38.000000000 -0500
++++ b/XML/RSS.php 2022-01-11 09:09:34.745242886 -0500
+@@ -202,7 +202,7 @@
+ * @return void
+ * @access private
+ */
+- function startHandler($parser, $element, &$attribs)
++ function startHandler($parser, $element, $attribs)
+ {
+ if (substr($element, 0, 4) == "RSS:") {
+ $element = substr($element, 4);