summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/authres')
-rw-r--r--dev-python/authres/authres-1.1.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/authres/authres-1.1.1.ebuild b/dev-python/authres/authres-1.1.1.ebuild
index 0823667ce457..9beb27ee9cfe 100644
--- a/dev-python/authres/authres-1.1.1.ebuild
+++ b/dev-python/authres/authres-1.1.1.ebuild
@@ -16,6 +16,6 @@ SLOT="0"
IUSE=""
python_test() {
- "${PYTHON}" -c "import sys, authres, doctest; f, t = doctest.testfile('authres/tests'); \
- sys.exit(bool(f))" || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" -m doctest -v authres/tests ||
+ die "Tests fail with ${EPYTHON}"
}