summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-1.4.1.ebuild30
-rw-r--r--dev-python/bleach/metadata.xml9
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
new file mode 100644
index 000000000000..065bab110d8a
--- /dev/null
+++ b/dev-python/bleach/Manifest
@@ -0,0 +1 @@
+DIST bleach-1.4.1.tar.gz 17449 SHA256 152af29d4580b112fc52966864492791c951e6382b56070e95e128c6b614833b SHA512 247dd02e3123149f8c0dd72e91e3942055d560be791f275ce52ce0250406033b2adfb47e257cb6af2dfd3dfc167ed6434c4cf4b906303e2cd96359d77b55482c WHIRLPOOL 015b4fb0d825201cc59188caf8d94e3d3b1af336ee3f0c787e07d8a73ec32f727c6640828e694b21e2dd255253416e25e11e44d8932bbbca5571494096b75020
diff --git a/dev-python/bleach/bleach-1.4.1.ebuild b/dev-python/bleach/bleach-1.4.1.ebuild
new file mode 100644
index 000000000000..c6b262c6be0a
--- /dev/null
+++ b/dev-python/bleach/bleach-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/jsocol/bleach https://pypi.python.org/pypi/bleach"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/html5lib-0.999[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/nose-1.3[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/bleach/metadata.xml b/dev-python/bleach/metadata.xml
new file mode 100644
index 000000000000..0d1b788bc7f1
--- /dev/null
+++ b/dev-python/bleach/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">bleach</remote-id>
+ <remote-id type="github">jsocol/bleach</remote-id>
+ </upstream>
+</pkgmetadata>