summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doit-py')
-rw-r--r--dev-python/doit-py/doit-py-0.4.0-r1.ebuild37
-rw-r--r--dev-python/doit-py/doit-py-0.4.0.ebuild41
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-python/doit-py/doit-py-0.4.0-r1.ebuild b/dev-python/doit-py/doit-py-0.4.0-r1.ebuild
deleted file mode 100644
index a23ebb2f495a..000000000000
--- a/dev-python/doit-py/doit-py-0.4.0-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="doit tasks for python stuff"
-HOMEPAGE="https://pythonhosted.org/doit-py/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? (
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- app-text/hunspell )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND="
- dev-python/doit[${PYTHON_USEDEP}]
- dev-python/configclass[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/doit-py/doit-py-0.4.0.ebuild b/dev-python/doit-py/doit-py-0.4.0.ebuild
deleted file mode 100644
index fae2a43f880d..000000000000
--- a/dev-python/doit-py/doit-py-0.4.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="doit tasks for python stuff"
-HOMEPAGE="https://pythonhosted.org/doit-py/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- app-text/hunspell )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND="
- dev-python/doit[${PYTHON_USEDEP}]
- dev-python/configclass[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}