summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numexpr/numexpr-2.4.3.ebuild')
-rw-r--r--dev-python/numexpr/numexpr-2.4.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/numexpr/numexpr-2.4.3.ebuild b/dev-python/numexpr/numexpr-2.4.3.ebuild
index 40aa4ecea9db..34e62183e34b 100644
--- a/dev-python/numexpr/numexpr-2.4.3.ebuild
+++ b/dev-python/numexpr/numexpr-2.4.3.ebuild
@@ -23,6 +23,8 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
+PATCHES=( "${FILESDIR}"/${P}-testfix.patch )
+
python_prepare_all() {
# TODO: mkl can be used but it fails for me
# only works with mkl in tree. newer mkl will use pkgconfig
@@ -46,8 +48,6 @@ python_compile() {
}
python_test() {
- # https://github.com/pydata/numexpr/issues/177
- # there are 2 known test failures under py3 only
pushd "${BUILD_DIR}"/lib > /dev/null
"${PYTHON}" -c "import numexpr; numexpr.test()" || die
pushd > /dev/null