summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/numpy-1.13.3.ebuild4
-rw-r--r--dev-python/numpy/numpy-1.14.5.ebuild2
-rw-r--r--dev-python/numpy/numpy-1.15.4.ebuild2
-rw-r--r--dev-python/numpy/numpy-1.16.1.ebuild2
-rw-r--r--dev-python/numpy/numpy-9999.ebuild2
5 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/numpy/numpy-1.13.3.ebuild b/dev-python/numpy/numpy-1.13.3.ebuild
index 7242f6777759..38ab8f14ce32 100644
--- a/dev-python/numpy/numpy-1.13.3.ebuild
+++ b/dev-python/numpy/numpy-1.13.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -127,7 +127,7 @@ python_prepare_all() {
}
python_compile() {
- export MAKEOPTS=-j1 # bug #660754
+ use !lapack && export MAKEOPTS=-j1 #660754
local python_makeopts_jobs=""
python_is_python3 || python_makeopts_jobs="-j $(makeopts_jobs)"
diff --git a/dev-python/numpy/numpy-1.14.5.ebuild b/dev-python/numpy/numpy-1.14.5.ebuild
index 630b5d21ec69..e48e1dc70343 100644
--- a/dev-python/numpy/numpy-1.14.5.ebuild
+++ b/dev-python/numpy/numpy-1.14.5.ebuild
@@ -114,6 +114,8 @@ python_prepare_all() {
}
python_compile() {
+ use !lapack && export MAKEOPTS=-j1 #660754
+
local python_makeopts_jobs=""
python_is_python3 || python_makeopts_jobs="-j $(makeopts_jobs)"
distutils-r1_python_compile \
diff --git a/dev-python/numpy/numpy-1.15.4.ebuild b/dev-python/numpy/numpy-1.15.4.ebuild
index 321b3a2e6722..5e43b353b724 100644
--- a/dev-python/numpy/numpy-1.15.4.ebuild
+++ b/dev-python/numpy/numpy-1.15.4.ebuild
@@ -109,6 +109,8 @@ python_prepare_all() {
}
python_compile() {
+ use !lapack && export MAKEOPTS=-j1 #660754
+
local python_makeopts_jobs=""
python_is_python3 || python_makeopts_jobs="-j $(makeopts_jobs)"
distutils-r1_python_compile \
diff --git a/dev-python/numpy/numpy-1.16.1.ebuild b/dev-python/numpy/numpy-1.16.1.ebuild
index bf2f0cc9d3b7..ecb913628ef6 100644
--- a/dev-python/numpy/numpy-1.16.1.ebuild
+++ b/dev-python/numpy/numpy-1.16.1.ebuild
@@ -112,6 +112,8 @@ python_prepare_all() {
}
python_compile() {
+ use !lapack && export MAKEOPTS=-j1 #660754
+
local python_makeopts_jobs=""
python_is_python3 || python_makeopts_jobs="-j $(makeopts_jobs)"
distutils-r1_python_compile \
diff --git a/dev-python/numpy/numpy-9999.ebuild b/dev-python/numpy/numpy-9999.ebuild
index baa28ab58893..7232ea8a951e 100644
--- a/dev-python/numpy/numpy-9999.ebuild
+++ b/dev-python/numpy/numpy-9999.ebuild
@@ -104,6 +104,8 @@ python_prepare_all() {
}
python_compile() {
+ use !lapack && export MAKEOPTS=-j1 #660754
+
distutils-r1_python_compile -j $(makeopts_jobs) ${NUMPY_FCONFIG}
}