summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pony')
-rw-r--r--dev-python/pony/Manifest1
-rw-r--r--dev-python/pony/metadata.xml7
-rw-r--r--dev-python/pony/pony-0.7.13.ebuild26
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pony/Manifest b/dev-python/pony/Manifest
new file mode 100644
index 000000000000..dec2b3288581
--- /dev/null
+++ b/dev-python/pony/Manifest
@@ -0,0 +1 @@
+DIST pony-0.7.13.gh.tar.gz 302541 BLAKE2B a1e6f82c6eb72f8626238cbfcc0bc01d1ad3498a75a5ce4c3b8a4511e6d1fbfdd39a239f0462458ae1d64dc9446b338bbaea33d6bbdd861c8d0738e50d58a717 SHA512 431d19e3297ba1cdae5313948123d8b8cd71ee8ad5868b8cc2f5447eb435875fdbcdc3768834b9afe22ce8e4c1abaabeb597f3e6974b00aab33aa61e497d6390
diff --git a/dev-python/pony/metadata.xml b/dev-python/pony/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/pony/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pony/pony-0.7.13.ebuild b/dev-python/pony/pony-0.7.13.ebuild
new file mode 100644
index 000000000000..f5db45c4fdd2
--- /dev/null
+++ b/dev-python/pony/pony-0.7.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+inherit distutils-r1
+
+DESCRIPTION="Python ORM with beautiful query syntax"
+HOMEPAGE="
+ https://ponyorm.org/
+ https://github.com/ponyorm/pony/"
+SRC_URI="
+ https://github.com/ponyorm/pony/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( $(python_gen_impl_dep sqlite) )"
+
+distutils_enable_tests unittest