summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ptyprocess')
-rw-r--r--dev-python/ptyprocess/Manifest1
-rw-r--r--dev-python/ptyprocess/ptyprocess-0.5.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ptyprocess/Manifest b/dev-python/ptyprocess/Manifest
index d18d3bd5f6f7..119514cf0c68 100644
--- a/dev-python/ptyprocess/Manifest
+++ b/dev-python/ptyprocess/Manifest
@@ -1 +1,2 @@
+DIST ptyprocess-0.5.1.tar.gz 68474 SHA256 0530ce63a9295bfae7bd06edc02b6aa935619f486f0f1dc0972f516265ee81a6 SHA512 9e7481e8e3facde73086ef0728a57516a15b6bc2a5fb6bf6d6f892c396c9376d9d6334ee37737f3469929c4086d5678a2c5deaf44d70589d41644a98f2239dad WHIRLPOOL ba327a02a847f7c5e4b62e6bf8ba0f070f8a22ff584045d7ed3cc134f8a922b9d75e397992cd5df5ca4569f563d234ea2a194b5a557606978a37a4f04559ee1e
DIST ptyprocess-0.5.tar.gz 14923 SHA256 dcb78fb2197b49ca1b7b2f37b047bc89c0da7a90f90bd5bc17c3ce388bb6ef59 SHA512 6619bfc1dfc7c980ffc72dba62697692eb749f19500616e8783cfdc3c35980276eb39070f4cd7932775abb5e798c921b9320c5f51b9052f526585f01cd56259e WHIRLPOOL b1bd0da485ea106a3d366ab21dc714418b8d392a32fc3386ef734362da8ee455a38f9330cedfe35687be09bea3ff622c54440119fca72d7787d9a29518717b77
diff --git a/dev-python/ptyprocess/ptyprocess-0.5.1.ebuild b/dev-python/ptyprocess/ptyprocess-0.5.1.ebuild
new file mode 100644
index 000000000000..bb61a1780a2a
--- /dev/null
+++ b/dev-python/ptyprocess/ptyprocess-0.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Run a subprocess in a pseudo terminal"
+HOMEPAGE="https://github.com/pexpect/ptyprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test --verbose --verbose || die
+}