summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypcap/pypcap-1.2.1.ebuild')
-rw-r--r--dev-python/pypcap/pypcap-1.2.1.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/pypcap/pypcap-1.2.1.ebuild b/dev-python/pypcap/pypcap-1.2.1.ebuild
deleted file mode 100644
index e182ed45ee84..000000000000
--- a/dev-python/pypcap/pypcap-1.2.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Simplified object-oriented Python extension module for libpcap"
-HOMEPAGE="https://github.com/pynetwork/pypcap https://pypi.org/project/pypcap/"
-SRC_URI="https://github.com/pynetwork/pypcap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- net-libs/libpcap
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.1.6-mktemp.patch
-)
-
-python_compile() {
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}