summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypugjs')
-rw-r--r--dev-python/pypugjs/Manifest1
-rw-r--r--dev-python/pypugjs/metadata.xml21
-rw-r--r--dev-python/pypugjs/pypugjs-5.9.4.ebuild22
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pypugjs/Manifest b/dev-python/pypugjs/Manifest
new file mode 100644
index 000000000000..9392e3a8d2de
--- /dev/null
+++ b/dev-python/pypugjs/Manifest
@@ -0,0 +1 @@
+DIST v5.9.4.tar.gz 42179 BLAKE2B 6ba3ab0b5c4c2828a091c82d5e937ebd1f575f5a9ebd989fbcfa3c17b85471f084d04b641895e8bd4af32ca0c26c430c5d989287824e0bc67f1943fae3bb0caa SHA512 24ebf306a76afab570cb13806d27e12766163bb114a8e4fe20ee5f19eb7311203e8b647eeb2f150efb2f9dfa1db9e56f4218cc3deb15d81f22b12d1b11f83c32
diff --git a/dev-python/pypugjs/metadata.xml b/dev-python/pypugjs/metadata.xml
new file mode 100644
index 000000000000..e44a0f59610d
--- /dev/null
+++ b/dev-python/pypugjs/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>andy@freilandkiwis.de</email>
+ <name>Andy Grabow</name>
+ </maintainer>
+ <remote-id type="pypi">pypugjs</remote-id>
+ <remote-id type="github">kakulukia/pypugjs</remote-id>
+ </upstream>
+ <longdescription>PyPugJS is a fork of PyJade with the name Jade changed to PugJS.
+PyPuJS is a high performance port of Jade-lang for python,
+that converts any .pug source to any of the Template-language (Django,
+Jinja2, Mako or Tornado).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pypugjs/pypugjs-5.9.4.ebuild b/dev-python/pypugjs/pypugjs-5.9.4.ebuild
new file mode 100644
index 000000000000..dfa04c48288d
--- /dev/null
+++ b/dev-python/pypugjs/pypugjs-5.9.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pug (Jade) syntax adapter for Django, Jinja2 and Mako templates"
+HOMEPAGE="https://github.com/kakulukia/pypugjs"
+SRC_URI="https://github.com/kakulukia/pypugjs/archive/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/chardet
+"
+DEPEND="${RDEPEND}"