summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-4.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index ab2f423b22ee..f9cd0ce843b2 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1 +1,2 @@
DIST pytest-django-3.10.0.gh.tar.gz 68995 BLAKE2B dcc9ddceda88c32dab559c065feb347582e72ec5fcd9929cb2bde091bd5c89bbe09879901daf5dc0adc7e38921de5b4989e0d1bbefaa5eb1cdce1dfd2ef58a11 SHA512 7f66fa9287fb80082018613ec3b15a0da3f7a13075e85f0a2eff9e13358c993e56245c441d952d13f232bf7e49a05c799b4affbb844e90abaac736d86bb0a6c9
+DIST pytest-django-4.0.0.gh.tar.gz 67041 BLAKE2B 74971186666498a39afca4ad273b932579ce425df439805b6f1e36eadfa916dfaa4affc29ce2987ac62d38ae517140cedbeb9a20c6e13e2362af21878f4694a5 SHA512 411a28b6e2f4cef8a0bae1ce3a937e47fa11728a873ec6a8de6599d02e5a548548ecf56d896600924acfbc0a74c651c66f9d7c4d772ce572879c17bccd3bb27d
diff --git a/dev-python/pytest-django/pytest-django-4.0.0.ebuild b/dev-python/pytest-django/pytest-django-4.0.0.ebuild
new file mode 100644
index 000000000000..7e83c607671a
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.org
+ https://github.com/pytest-dev/pytest-django"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}