summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-iptables')
-rw-r--r--dev-python/python-iptables/Manifest1
-rw-r--r--dev-python/python-iptables/python-iptables-1.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-iptables/Manifest b/dev-python/python-iptables/Manifest
index c8bfab36f5bd..c94ad37ec5fd 100644
--- a/dev-python/python-iptables/Manifest
+++ b/dev-python/python-iptables/Manifest
@@ -1 +1,2 @@
DIST python-iptables-0.13.0.tar.gz 83456 BLAKE2B 9c8da40437d408c6bb49e700b8d1663e7fdb0a1001b15409cf4c8b9edf612f75eb546207bc86d0535f8fb3744e42244f3e067dff80037c5a3eadc028ec8024f3 SHA512 1693924b8ee79b3b0929b57e86908282d53d28044b063d7bd169a6e9c1b45b5b6b4a79e54d024beedbfd6e42f88417eb2d0312bf90895702a3b8bfe2c2eb22b2
+DIST python-iptables-1.0.0.tar.gz 52245 BLAKE2B f61cf655440a40c96e49452caa1070046e539313ce709c629cb93c11ac66d51dad5fb11c183a8babbba5766b8bea27d0ab604d7aec104775371791cedc2262f6 SHA512 417ebec4391c6967f3b1cfa56d79dc1c6d053570d71bb29713ed327ee1fd52e0be9c3b9a62a1ae666644bbb472e5174402584cd5ddfb0b24c11e1d30773bcea5
diff --git a/dev-python/python-iptables/python-iptables-1.0.0.ebuild b/dev-python/python-iptables/python-iptables-1.0.0.ebuild
new file mode 100644
index 000000000000..53037c8775b5
--- /dev/null
+++ b/dev-python/python-iptables/python-iptables-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for iptables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-firewall/iptables"
+
+# tests manipulate live iptables rules, so disable them by default
+RESTRICT="test"
+
+distutils_enable_sphinx doc
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}