summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/socketio-client/Manifest2
-rw-r--r--dev-python/socketio-client/socketio-client-0.5.6.ebuild36
-rw-r--r--dev-python/socketio-client/socketio-client-0.6.5.ebuild46
3 files changed, 47 insertions, 37 deletions
diff --git a/dev-python/socketio-client/Manifest b/dev-python/socketio-client/Manifest
index 300887009fed..4b4ac53e6efe 100644
--- a/dev-python/socketio-client/Manifest
+++ b/dev-python/socketio-client/Manifest
@@ -1 +1 @@
-DIST socketio-client-0.5.6.tar.gz 12069 SHA256 540d8ab209154d1d9cdb97c170c589a14f7d7f17e19c14e2f59f0307e6175485 SHA512 2ab316823cce0201b0c3a55b04a04fa39fe97f990b879fd5b45ccf6fa2ee6412d8c08d9892120f9a98fcf438e7e6302cf319a4df6cda061b90e1d802580563b9 WHIRLPOOL 6ba7f776ab0af9ae5efb0aca3d908daa018a83dd69e0a490efcd03c912c1c402d5c9a1381804df8cce333566182c76b321c4dd6bf14c948ede984aa752152dab
+DIST socketio-client-0.6.5.tar.gz 18387 SHA256 843f271074e6d2b1302ab873d2dfb37e647aea03c75d542fdd0f47b9d81085bc SHA512 76a60089964ddba2733780b96fb079ad60640dea3f457b91217c2e64541c03ec7c9c653dd961285a1858d01ed13722ea60a16fac13fbd778cc0c9a720fd31a1f WHIRLPOOL d557a892686025fe0f08afc65dc4c442eea67494671351bb9ca7a05bf37e1224c3e8f3997422e80b10b7d6b7ade452e06828c6e3fe52ff4e36cc8bef6f45e127
diff --git a/dev-python/socketio-client/socketio-client-0.5.6.ebuild b/dev-python/socketio-client/socketio-client-0.5.6.ebuild
deleted file mode 100644
index 0b67809aa159..000000000000
--- a/dev-python/socketio-client/socketio-client-0.5.6.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_{3,4}} )
-
-inherit distutils-r1
-
-MY_PN="socketIO-client"
-DESCRIPTION="A socket.io client library for Python"
-HOMEPAGE="https://github.com/invisibleroads/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-RESTRICT="test"
-
-python_test() {
- PYTHONPATH="${PWD}" python -m unittest
-}
diff --git a/dev-python/socketio-client/socketio-client-0.6.5.ebuild b/dev-python/socketio-client/socketio-client-0.6.5.ebuild
new file mode 100644
index 000000000000..788c192c998f
--- /dev/null
+++ b/dev-python/socketio-client/socketio-client-0.6.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+MY_PN="socketIO-client"
+REPO_PN="socketIO_client"
+DESCRIPTION="A socket.io client library for Python"
+HOMEPAGE="https://github.com/invisibleroads/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${REPO_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${REPO_PN}-${PV}"
+
+python_test() {
+ # https://github.com/invisibleroads/socketIO-client/issues/90
+ # This runs the suite but has nill output to the screen
+ # The bug filed will hopefully yield a more conventional testsuite
+
+ # The import of SocketIO need be made with abs path to run the tests
+ sed -e 's:from .. import:from socketIO_client import:' \
+ -i ${REPO_PN}/tests/__init__.py || die
+
+ "${PYTHON}" ${REPO_PN}/tests/__init__.py || die "Tests failed under ${EPYTHON}"
+
+ # Return to original form for final install
+ sed -e 's:from socketIO_client import:from .. import:' \
+ -i ${REPO_PN}/tests/__init__.py || die
+}