summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx/files/sphinx-3.3.1-doc-link.patch14
-rw-r--r--dev-python/sphinx/sphinx-3.3.1.ebuild4
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/sphinx/files/sphinx-3.3.1-doc-link.patch b/dev-python/sphinx/files/sphinx-3.3.1-doc-link.patch
new file mode 100644
index 000000000000..0c1b2ad7d98c
--- /dev/null
+++ b/dev-python/sphinx/files/sphinx-3.3.1-doc-link.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/728810
+--- ./doc/internals/release-process.rst
++++ ./doc/internals/release-process.rst
+@@ -97,8 +97,8 @@
+ * ``set PYTHONWARNINGS=`` and do ``make html`` (Windows)
+
+ But you can also explicitly enable the pending ones using e.g.
+-``PYTHONWARNINGS=default`` (see the :ref:`Python docs on configuring warnings
+-<python:describing-warning-filters>`) for more details.
++``PYTHONWARNINGS=default`` (see the `Python docs on configuring warnings
++<https://docs.python.org/3/library/warnings.html#describing-warning-filters>`_) for more details.
+
+ Release procedures
+ ------------------
diff --git a/dev-python/sphinx/sphinx-3.3.1.ebuild b/dev-python/sphinx/sphinx-3.3.1.ebuild
index f29129962d65..f77fc4923c67 100644
--- a/dev-python/sphinx/sphinx-3.3.1.ebuild
+++ b/dev-python/sphinx/sphinx-3.3.1.ebuild
@@ -62,6 +62,10 @@ BDEPEND="
S="${WORKDIR}/${P^}"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.3.1-doc-link.patch"
+)
+
python_prepare_all() {
# remove tests that fail due to network-sandbox
rm tests/test_build_linkcheck.py || die "Failed to remove web tests"